summaryrefslogtreecommitdiff
path: root/plugins/pythonconsole/Makefile.am
diff options
context:
space:
mode:
authorPatrick Monnerat <[email protected]>2019-05-22 18:02:59 +0200
committerraveit65 <[email protected]>2019-06-05 22:00:27 +0200
commitfd4405cc794d6fd3d560f06cfbaecca08e16a51e (patch)
treefbf547fd229dcd1ff4df06f1e27bdc27322dfecc /plugins/pythonconsole/Makefile.am
parentce58b8815723b198a48202750e46e6deb2012c2d (diff)
downloadpluma-fd4405cc794d6fd3d560f06cfbaecca08e16a51e.tar.bz2
pluma-fd4405cc794d6fd3d560f06cfbaecca08e16a51e.tar.xz
pythonconsole plugin: change source code for Python 2 & 3 compatibility.
Also drop mateconf and use gsettings for preferences. Preferences are now triggered as a PeasGtk.Configurable.
Diffstat (limited to 'plugins/pythonconsole/Makefile.am')
-rw-r--r--plugins/pythonconsole/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/plugins/pythonconsole/Makefile.am b/plugins/pythonconsole/Makefile.am
index 0a9ff965..51a2e4a4 100644
--- a/plugins/pythonconsole/Makefile.am
+++ b/plugins/pythonconsole/Makefile.am
@@ -7,9 +7,22 @@ plugin_in_files = pythonconsole.plugin.desktop.in
plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
-EXTRA_DIST = $(plugin_in_files)
+pythonconsole_gschema_in = org.mate.pluma.plugins.pythonconsole.gschema.xml.in
+gsettings_SCHEMAS = $(pythonconsole_gschema_in:.xml.in=.xml)
+@GSETTINGS_RULES@
-CLEANFILES = $(plugin_DATA)
-DISTCLEANFILES = $(plugin_DATA)
+EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(pythonconsole_gschema_in)
+
+CLEANFILES = \
+ $(plugin_DATA) \
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS)
+
+DISTCLEANFILES = \
+ $(plugin_DATA) \
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk