summaryrefslogtreecommitdiff
path: root/pluma/smclient/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2020-06-18 14:53:13 +0800
committerraveit65 <[email protected]>2020-06-30 21:22:47 +0200
commit305119909b6f859ab3ff832fec5559a129c98db2 (patch)
tree022c42d3517df560425aa85f8a6eb3d7635672d8 /pluma/smclient/Makefile.am
parent024ccef079c00b132645e5bd3179369b60676beb (diff)
downloadpluma-305119909b6f859ab3ff832fec5559a129c98db2.tar.bz2
pluma-305119909b6f859ab3ff832fec5559a129c98db2.tar.xz
use libegg submodules
Diffstat (limited to 'pluma/smclient/Makefile.am')
-rw-r--r--pluma/smclient/Makefile.am39
1 files changed, 0 insertions, 39 deletions
diff --git a/pluma/smclient/Makefile.am b/pluma/smclient/Makefile.am
deleted file mode 100644
index 56d35d06..00000000
--- a/pluma/smclient/Makefile.am
+++ /dev/null
@@ -1,39 +0,0 @@
-platform_defines = -DEGG_SM_CLIENT_BACKEND_XSMP
-platform_libs = libeggdesktopfile.la
-platform_ltlibraries = libeggdesktopfile.la
-platform_sources = eggsmclient-xsmp.c
-
-AM_CPPFLAGS = \
- -DG_LOG_DOMAIN=\""EggSMClient"\" \
- $(PLUMA_CFLAGS) \
- $(platform_defines) \
- $(EGG_SMCLIENT_CFLAGS)
-
-noinst_LTLIBRARIES = \
- libeggsmclient.la \
- $(platform_ltlibraries)
-
-libeggsmclient_la_LIBADD = \
- $(EGG_SMCLIENT_LIBS) \
- $(platform_libs)
-
-libeggsmclient_la_LDFLAGS = \
- $(platform_ldflags)
-
-libeggsmclient_la_SOURCES = \
- eggsmclient.c \
- eggsmclient.h \
- eggsmclient-private.h \
- $(platform_sources)
-
-libeggdesktopfile_la_LIBADD = \
- $(EGG_LIBS)
-
-libeggdesktopfile_la_SOURCES = \
- eggdesktopfile.c \
- eggdesktopfile.h
-
-EXTRA_DIST = \
- eggsmclient-xsmp.c
-
--include $(top_srcdir)/git.mk