summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-07 16:46:58 -0300
committerPerberos <[email protected]>2011-11-07 16:46:58 -0300
commit528c1e5ff51e213936e800fc5a9a25da99c0bdf2 (patch)
tree77f8aa456b09367ba81f04d4562fc935f898a951 /tests/Makefile.am
downloadpluma-528c1e5ff51e213936e800fc5a9a25da99c0bdf2.tar.bz2
pluma-528c1e5ff51e213936e800fc5a9a25da99c0bdf2.tar.xz
initial
Diffstat (limited to 'tests/Makefile.am')
-rwxr-xr-xtests/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100755
index 00000000..f54ce8c7
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,28 @@
+INCLUDES = -g -I$(top_srcdir) -I$(top_srcdir)/gedit $(GEDIT_DEBUG_FLAGS) $(GEDIT_CFLAGS)
+
+noinst_PROGRAMS = $(TEST_PROGS)
+progs_ldadd = $(top_builddir)/gedit/libgedit.la
+
+TEST_PROGS = smart-converter
+smart_converter_SOURCES = smart-converter.c
+smart_converter_LDADD = $(progs_ldadd)
+
+TEST_PROGS += document-input-stream
+document_input_stream_SOURCES = document-input-stream.c
+document_input_stream_LDADD = $(progs_ldadd)
+
+TEST_PROGS += document-output-stream
+document_output_stream_SOURCES = document-output-stream.c
+document_output_stream_LDADD = $(progs_ldadd)
+
+TEST_PROGS += document-loader
+document_loader_SOURCES = document-loader.c
+document_loader_LDADD = $(progs_ldadd)
+
+TEST_PROGS += document-saver
+document_saver_SOURCES = document-saver.c
+document_saver_LDADD = $(progs_ldadd)
+
+TESTS = $(TEST_PROGS)
+
+EXTRA_DIST = setup-document-saver.sh