summaryrefslogtreecommitdiff
path: root/tools/plugin_template/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2014-01-29 16:07:41 +0100
committerStefano Karapetsas <[email protected]>2014-01-29 16:07:41 +0100
commit5697065e11fd593042ad572ba032b96fddad9cb5 (patch)
treea4a0e57436af53712d1c3f9d7f1d4be2f1c292ee /tools/plugin_template/Makefile.am
parentf9933b9afdf50f311b48749fd4b6f88323f22665 (diff)
downloadpluma-5697065e11fd593042ad572ba032b96fddad9cb5.tar.bz2
pluma-5697065e11fd593042ad572ba032b96fddad9cb5.tar.xz
Add tool to generate plugin templates
Diffstat (limited to 'tools/plugin_template/Makefile.am')
-rw-r--r--tools/plugin_template/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/tools/plugin_template/Makefile.am b/tools/plugin_template/Makefile.am
new file mode 100644
index 00000000..93c79ae7
--- /dev/null
+++ b/tools/plugin_template/Makefile.am
@@ -0,0 +1,37 @@
+# ##(PLUGIN_NAME)
+
+plugindir = $(PLUMA_PLUGINS_LIBS_DIR)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ $(PLUMA_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS) \
+ -DPLUMA_LOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\"
+
+plugin_LTLIBRARIES = lib##(PLUGIN_MODULE).la
+
+lib##(PLUGIN_MODULE)_la_SOURCES = \
+ ##(PLUGIN_MODULE)-plugin.h \
+ ##(PLUGIN_MODULE)-plugin.c
+
+lib##(PLUGIN_MODULE)_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+lib##(PLUGIN_MODULE)_la_LIBADD = $(PLUMA_LIBS)
+
+# UI files (if you use gtkbuilder for your plugin, list those files here)
+uidir = $(PLUMA_PLUGINS_DATA_DIR)/##(PLUGIN_MODULE)
+ui_DATA =
+
+plugin_in_files = ##(PLUGIN_MODULE).pluma-plugin.desktop.in
+
+%.pluma-plugin: %.pluma-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
+
+EXTRA_DIST = $(plugin_in_files)
+
+CLEANFILES = $(plugin_DATA) $(ui_DATA)
+
+DISTCLEANFILES = $(plugin_DATA) $(ui_DATA)
+
+-include $(top_srcdir)/git.mk