summaryrefslogtreecommitdiff
path: root/plugins/filebrowser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/filebrowser/Makefile.am')
-rw-r--r--plugins/filebrowser/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/plugins/filebrowser/Makefile.am b/plugins/filebrowser/Makefile.am
index 903e5bc7..095cdc1d 100644
--- a/plugins/filebrowser/Makefile.am
+++ b/plugins/filebrowser/Makefile.am
@@ -44,8 +44,10 @@ uidir = $(PLUMA_PLUGINS_DATA_DIR)/filebrowser
ui_DATA = pluma-file-browser-widget-ui.xml
plugin_in_files = filebrowser.plugin.desktop.in
+plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
-%.plugin: %.plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(plugin_DATA): $(plugin_in_files)
+ $(AM_V_GEN) $(MSGFMT) --keyword=Name --keyword=Description --desktop --template $< -d $(top_srcdir)/po -o $@
pluma-file-browser-enum-types.h: pluma-file-browser-enum-types.h.template $(NOINST_H_FILES) $(GLIB_MKENUMS)
(cd $(srcdir) && $(GLIB_MKENUMS) --template pluma-file-browser-enum-types.h.template $(NOINST_H_FILES)) > $@
@@ -62,9 +64,6 @@ pluma-file-browser-marshal.c: pluma-file-browser-marshal.list $(GLIB_GENMARSHAL)
$(AM_V_GEN) echo "#include \"pluma-file-browser-marshal.h\"" > $@ && \
$(GLIB_GENMARSHAL) $< --body --prefix=pluma_file_browser_marshal >> $@
-plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
-
-@INTLTOOL_XML_NOMERGE_RULE@
filebrowser_gschema_in = org.mate.pluma.plugins.filebrowser.gschema.xml.in
gsettings_SCHEMAS = $(filebrowser_gschema_in:.xml.in=.xml)
@GSETTINGS_RULES@