summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorPatrick Monnerat <[email protected]>2019-02-17 17:36:11 +0100
committerraveit65 <[email protected]>2019-03-31 12:30:00 +0200
commit1d5a8b7aa497c6d3d3257887f95832eda397347c (patch)
tree65471eef27198f9eeb9cf5c3c7f79fb05c13a729 /docs/Makefile.am
parent75906bebc8b7ce8adef7040d5bebde8ff7f59090 (diff)
downloadpython-caja-1d5a8b7aa497c6d3d3257887f95832eda397347c.tar.bz2
python-caja-1d5a8b7aa497c6d3d3257887f95832eda397347c.tar.xz
Make Caja.OperationHandle usable.
The Caja.OperationHandle.handle property is added: this gives access to the effective handle taking the form of a non-zero signed integer that can be stored in a void pointer. Trying to set this property with an invalid value raises an exception. Upon update_file_info_full call, the new Caja.OperationHandle is preset with a "unique" non-null value generated from an atomic counter. When the python method returns, the handle value is transmitted to Caja whatever it is: this fixes the problem of Caja expecting a non-null handle when CAJA_OPERATION_IN_PROGRESS is returned. Ref: https://github.com/mate-desktop/python-caja/issues/36
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 70021bc..b05ab92 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -24,7 +24,8 @@ XML_FILES = \
reference/caja-python-file-info.xml \
reference/caja-python-info-provider.xml \
reference/caja-python-enum-reference.xml \
- reference/caja-python-operation-result.xml
+ reference/caja-python-operation-result.xml \
+ reference/caja-python-operation-handle.xml
HTMLdir = $(datadir)/gtk-doc/html/caja-python
HTML_FILES = \
@@ -45,6 +46,7 @@ HTML_FILES = \
html/class-caja-python-location-widget-provider.html \
html/class-caja-python-file-info.html \
html/class-caja-python-info-provider.html \
+ html/class-caja-python-operation-handle.html \
html/caja-python-enum-reference.html \
html/enum-caja-python-operation-result.html \
html/caja-python.devhelp