summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-06-21 15:01:33 +0530
committerrootavish <[email protected]>2014-06-21 15:01:33 +0530
commite817bd447789cd670fb00b6507debfe84f8cf64f (patch)
treea5becf3393a1fbfbff864ba1fa03c53edcc65598 /configure.ac
parentd57fa16e9e8c9091ebf826af94a0c3ad1a593596 (diff)
downloadatril-e817bd447789cd670fb00b6507debfe84f8cf64f.tar.bz2
atril-e817bd447789cd670fb00b6507debfe84f8cf64f.tar.xz
Changed dependecy to webkit-1.0,added web view to window properties
Currently the backend/epub/epub-document.c file has some dummy code, such as that for thumbnails, solely to get it to build. Now that we are done with all functions that we would possibly need to handle the backend, I am now working now on displaying the document via a webview, starting with this commit where i add a webview to the EvWindow properties. Similar to this I need to put in custom functions for epub, as rendering is done by the layout engine. I will also need to add some epub specific callback functions to the widgets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 19bc4ba4..b7d1070a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -699,13 +699,13 @@ AC_ARG_ENABLE(epub,
if test "x$enable_epub" = "xyes"; then
WEBKIT_REQUIRED=2.4.2
- PKG_CHECK_MODULES(WEBKIT, webkit2gtk-3.0 >= $WEBKIT_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED zlib,enable_epub=yes,enable_epub=no)
+ PKG_CHECK_MODULES(WEBKIT, webkit-1.0 >= $WEBKIT_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED zlib,enable_epub=yes,enable_epub=no)
if test "x$enable_epub" = "xyes"; then
AC_DEFINE([ENABLE_EPUB], [1], [Enable support for ePub documents.])
else
enable_epub="no"
- AC_MSG_WARN(["ePub support is disabled since webkit2gtk-3.0( version >= $WEBKIT_REQUIRED ) is needed"])
+ AC_MSG_WARN(["ePub support is disabled since webkit-1.0( version >= $WEBKIT_REQUIRED ) is needed"])
fi
fi