summaryrefslogtreecommitdiff
path: root/mateweather/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mateweather/src/Makefile.am')
-rw-r--r--mateweather/src/Makefile.am45
1 files changed, 32 insertions, 13 deletions
diff --git a/mateweather/src/Makefile.am b/mateweather/src/Makefile.am
index b01bc226..e30affd6 100644
--- a/mateweather/src/Makefile.am
+++ b/mateweather/src/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
AM_CPPFLAGS = \
-I$(srcdir) \
-I$(top_srcdir) \
@@ -7,23 +9,40 @@ AM_CPPFLAGS = \
$(LIBMATEWEATHER_CFLAGS) \
${WARN_CFLAGS}
-libexec_PROGRAMS = mateweather-applet
+BUILT_SOURCES = \
+ mateweather-resources.c \
+ mateweather-resources.h \
+ $(NULL)
+APPLET_SOURCES = \
+ mateweather.h \
+ main.c \
+ mateweather-about.c mateweather-about.h \
+ mateweather-pref.c mateweather-pref.h \
+ mateweather-dialog.c mateweather-dialog.h \
+ mateweather-applet.c mateweather-applet.h \
+ $(NULL)
-BUILT_SOURCES = mateweather-resources.c mateweather-resources.h
-nodist_mateweather_applet_SOURCES = $(BUILT_SOURCES)
-mateweather_applet_SOURCES = \
- mateweather.h \
- main.c \
- mateweather-about.c mateweather-about.h \
- mateweather-pref.c mateweather-pref.h \
- mateweather-dialog.c mateweather-dialog.h \
- mateweather-applet.c mateweather-applet.h
-
-mateweather_applet_LDADD = \
+APPLET_LIBS = \
$(LIBNOTIFY_LIBS) \
$(MATE_APPLETS4_LIBS) \
$(MATE_LIBS2_LIBS) \
- $(LIBMATEWEATHER_LIBS)
+ $(LIBMATEWEATHER_LIBS) \
+ $(NULL)
+
+if ENABLE_IN_PROCESS
+pkglib_LTLIBRARIES = libmateweather-applet.la
+nodist_libmateweather_applet_la_SOURCES = $(BUILT_SOURCES)
+libmateweather_applet_la_SOURCES = $(APPLET_SOURCES)
+libmateweather_applet_la_CFLAGS = $(AM_CFLAGS)
+libmateweather_applet_la_LDFLAGS = -module -avoid-version
+libmateweather_applet_la_LIBADD = $(APPLET_LIBS)
+else !ENABLE_IN_PROCESS
+libexec_PROGRAMS = mateweather-applet
+nodist_mateweather_applet_SOURCES = $(BUILT_SOURCES)
+mateweather_applet_SOURCES = $(APPLET_SOURCES)
+mateweather_applet_CFLAGS = $(AM_CFLAGS)
+mateweather_applet_LDADD = $(APPLET_LIBS)
+endif !ENABLE_IN_PROCESS
mateweather-resources.c: ../data/mateweather-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data/ --generate-dependencies $(srcdir)/../data/mateweather-resources.gresource.xml)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data/ --generate --c-name mateweather $<