summaryrefslogtreecommitdiff
path: root/abstract/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-30 18:59:39 -0300
committerPerberos <[email protected]>2011-11-30 18:59:39 -0300
commite59145232c55785c2d5687d615016e6250140e79 (patch)
treefc459bc643fa6f0c7ee37a234370bff28e08b200 /abstract/Makefile.am
downloadmate-backgrounds-e59145232c55785c2d5687d615016e6250140e79.tar.bz2
mate-backgrounds-e59145232c55785c2d5687d615016e6250140e79.tar.xz
moving from https://github.com/perberos/Mate-Desktop-Environment
Diffstat (limited to 'abstract/Makefile.am')
-rw-r--r--abstract/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/abstract/Makefile.am b/abstract/Makefile.am
new file mode 100644
index 0000000..4fd9678
--- /dev/null
+++ b/abstract/Makefile.am
@@ -0,0 +1,30 @@
+backgrounddir = $(datadir)/pixmaps/backgrounds/mate/abstract
+
+background_DATA = \
+ Arc-Colors-Transparent-Wallpaper.png \
+ Flow.png \
+ Gulp.png \
+ Silk.png \
+ Spring.png \
+ Waves.png \
+ stripes.jpg
+
+
+metadata_in_files = mate-abstract.xml.in
+metadatadir = $(datadir)/mate-background-properties
+metadata_DATA = $(metadata_in_files:.xml.in=.xml)
+@INTLTOOL_XML_RULE@
+
+noinst_DATA = mate-abstract.xml.in
+CLEANFILES = mate-abstract.xml mate-abstract.xml.in
+
+EXTRA_DIST = $(background_DATA) mate-abstract.xml.in.in
+
+mate-abstract.xml.in: mate-abstract.xml.in.in Makefile
+ $(AM_V_GEN)sed -e 's^\@datadir\@^$(datadir)^g' < $(srcdir)/mate-abstract.xml.in.in > mate-abstract.xml.in.tmp \
+ && mv mate-abstract.xml.in.tmp mate-abstract.xml.in
+
+MAINTAINERCLEANFILES = \
+ Makefile.in
+
+-include $(top_srcdir)/git.mk