summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 458d9ac..fd7f6a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([mate-session-manager], [1.26.0], [https://mate-desktop.org/])
+AC_INIT([mate-session-manager], [1.28.0], [https://mate-desktop.org/])
AC_CONFIG_SRCDIR([mate-session])
AC_CONFIG_HEADERS([config.h])
@@ -27,7 +27,7 @@ AC_SUBST(ACLOCAL_AMFLAGS, "\${ACLOCAL_FLAGS}")
MATE_MAINTAINER_MODE_DEFINES
AC_ARG_ENABLE(deprecations,
- [AC_HELP_STRING([--enable-deprecations],
+ [AS_HELP_STRING([--enable-deprecations],
[warn about deprecated usages @<:@default=no@:>@])],,
[enable_deprecations=no])
@@ -73,7 +73,7 @@ dnl ====================================================================
dnl GLESV2 (optional)
dnl ====================================================================
-AC_ARG_WITH([libglesv2], AC_HELP_STRING([--without-libglesv2], [disable GLESV2 support]))
+AC_ARG_WITH([libglesv2], AS_HELP_STRING([--without-libglesv2], [disable GLESV2 support]))
have_glesv2=no
if test x$with_libglesv2 != xno; then
PKG_CHECK_MODULES(GLES_TEST, egl glesv2, have_glesv2=yes, have_glesv2=no)
@@ -87,7 +87,7 @@ dnl ====================================================================
dnl Option to set the default window manager
dnl ====================================================================
AC_ARG_WITH(default-wm,
- [AC_HELP_STRING([--with-default-wm],
+ [AS_HELP_STRING([--with-default-wm],
[Specify the default window manager @<:@default=marco@:>@])],,
[with_default_wm="marco"])
@@ -193,7 +193,7 @@ dnl - DocBook Documentation
dnl ====================================================================
AC_ARG_ENABLE(docbook-docs,
- [AC_HELP_STRING([--enable-docbook-docs],
+ [AS_HELP_STRING([--enable-docbook-docs],
[build documentation (requires xmlto)])],
enable_docbook_docs=$enableval,enable_docbook_docs=auto)
AC_PATH_PROG(XMLTO, xmlto, no)
@@ -268,7 +268,7 @@ dnl Code for checking whether IPv6 is enabled on the system....
dnl ====================================================================
AC_MSG_CHECKING([whether to enable ipv6])
AC_ARG_ENABLE(ipv6,
- AC_HELP_STRING([--enable-ipv6], [enable IPv6 extensions]),,
+ AS_HELP_STRING([--enable-ipv6], [enable IPv6 extensions]),,
[enable_ipv6=yes])
have_full_ipv6=no
if test $enable_ipv6 = yes; then
@@ -315,7 +315,7 @@ AC_PATH_PROGS(PERL, perl5 perl)
# define a MAINT-like variable REBUILD which is set if Perl
# and awk are found, so autogenerated sources can be rebuilt
AC_ARG_ENABLE(rebuilds,
- AC_HELP_STRING([--disable-rebuilds],
+ AS_HELP_STRING([--disable-rebuilds],
[disable all source autogeneration rules]),,
[enable_rebuilds=yes])
REBUILD=\#
@@ -327,7 +327,7 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
capplet/Makefile
doc/Makefile
@@ -343,6 +343,7 @@ mate-session/Makefile
tools/Makefile
po/Makefile.in
])
+AC_OUTPUT
dnl ---------------------------------------------------------------------------
dnl - Show summary