summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-10 10:56:07 +0200
committerraveit65 <[email protected]>2016-04-10 11:01:26 +0200
commit0b9347305b94b0c0bc51db16a937a2f09459e1ef (patch)
tree287323f876bf17a7f4f66d7ff83b1c8ff3d2f12d /Makefile.am
parent7ddd81bcc9f87eb0aa5ba383efa99793beb375ec (diff)
downloadmate-themes-0b9347305b94b0c0bc51db16a937a2f09459e1ef.tar.bz2
mate-themes-0b9347305b94b0c0bc51db16a937a2f09459e1ef.tar.xz
Fix Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 193b6301..6d8e8565 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,20 +14,16 @@ EXTRA_DIST = \
DISTCLEANFILES=intltool-extract intltool-merge intltool-update
-dist-hook:
- @if test -d "$(srcdir)/.git"; \
- then \
- echo Creating ChangeLog && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
- || ( rm -f ChangeLog.tmp ; \
- echo Failed to generate ChangeLog >&2 ); \
- else \
- echo A git clone is required to generate a ChangeLog >&2; \
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
fi
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
# we don't want to install mo files, all translations are already stored
# in theme files
install-data-local: