summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 193b6301..6d8e8565 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,20 +14,16 @@ EXTRA_DIST = \
DISTCLEANFILES=intltool-extract intltool-merge intltool-update
-dist-hook:
- @if test -d "$(srcdir)/.git"; \
- then \
- echo Creating ChangeLog && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
- || ( rm -f ChangeLog.tmp ; \
- echo Failed to generate ChangeLog >&2 ); \
- else \
- echo A git clone is required to generate a ChangeLog >&2; \
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
fi
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
# we don't want to install mo files, all translations are already stored
# in theme files
install-data-local: